×
First posts must be approved (25 Oct 2018)

Due to the unwelcome increase in the number of spam posts on the site it is now required for everyone's first post to be approved by a moderator.

Read More...

emo strange valve

More
20 Aug 2013 18:47 #19416



this valve is connected electrically and to a vacuum pipe leading to the intake manifold but it has two other outputs/inputs that are unused, looks like the pipes are connected to the bov but im not sure what to do about it

Please Log in or Create an account to join the conversation.

More
21 Aug 2013 18:23 #19437

i would say thats the factroy boost controller, the 2 unused pipes go to the actuator and the other to the nipple on the turbo inlet housing, not sure what way round they go tho, just connect them and see if it raises the boost a bit or if it boosts its nuts of and it the fuel cut.
that would be why your running next to no boost i think mate

Please Log in or Create an account to join the conversation.

More
21 Aug 2013 18:27 #19438

to be more accurate its a air by-pass valve, (ie boost controller) suzuki denso part number denso 18114 64d00

translate.google.co.uk/translate?hl=en&s...zilla:en-US:official

get it pluged back in mate and will have more boost :cheer:

hope that helps

Please Log in or Create an account to join the conversation.

More
21 Aug 2013 19:11 #19439

Not sure where to plug it, no available hoses

Please Log in or Create an account to join the conversation.

More
21 Aug 2013 19:30 #19440

on the turbo inlet housing there will be a vacum line coming of it and going to the actuator (silver lolly pop looking thing on the turbo),
pull that of and with some longer hose run a length from the nipple on the turbo housing to 1 of ther ports on the valve, then another from the other port on the valve to the actuator, take it for a test drive and see if the boost changes, if it over boosts a lot, stop and swap the hoses over on the valve and test again

Please Log in or Create an account to join the conversation.

More
21 Aug 2013 19:32 #19441

actualy looking at the pics on of the ports (sticking out bit of tubluar plastic)on the valve has snapped?? if so your nto gonna be able to any thing with it inless you by a new 1 or a boost controller

Please Log in or Create an account to join the conversation.

More
21 Aug 2013 19:55 #19442



Those are the hoses

Might be able to get something on it, it's only slightly broke

Please Log in or Create an account to join the conversation.

More
21 Aug 2013 20:03 #19443

Seen the lollipop lol, there's a small hose going from it, about 2 inches long to the other side of the turbo, I'll get a picture

Please Log in or Create an account to join the conversation.

More
21 Aug 2013 20:04 #19444

the bov should not be plumbed in to the valve, try and find a port on the intake manifold after the throttle bodie and run the bov vacum hose strait to the port on intake
if you can stick up a larger engine bay pic so i can see were the turbo is ect ect and can try and help a bit better or if your board and fancy a drive down south to see if can sort it out pop down to me

Please Log in or Create an account to join the conversation.

More
21 Aug 2013 20:07 #19445

Coming to the meet on the 8th?

Please Log in or Create an account to join the conversation.

Moderators: TADOAdam Kenneydazran
Time to create page: 0.229 seconds
Powered by Kunena Forum