emo New beat owner

More
22 Jul 2013 15:30 #18982

Hi there and welcome. B)

I'm sure one of our Beat experts will be along shortly to offer their advice :)

Please Log in or Create an account to join the conversation.

More
22 Jul 2013 15:32 #18983

Hi Paul, welcome to KKITP. ;)

Please Log in or Create an account to join the conversation.

  • TADO
  • TADO's Avatar
  • Offline
  • Committee Member
  • General Pest / Cake Botherer
More
22 Jul 2013 16:56 #18984

welcome aboard paul
fraid i cant offer much help with the throttle problem, but if you let me know your username i'll log into the admin on the beat forum and approve your user account :D



www.u-ukhbc.co.uk The Unoffical UK Honda Beat Club
Minkara Page: bit.ly/gXbOvH
Work: www.tado.co.uk

Please Log in or Create an account to join the conversation.

More
22 Jul 2013 21:33 #18996

Hi Paul and Welcome :)

I recently had a lot of sensor probs on my Beat, most of them went away when I pulled the plugs and cleaned up the connectors - the only one I had to replace was the Lambda sensor in the end but it was a bit of trial and error!

burn and coast sounds like a bit of a pain, I assume you've checked all the normal stufff like plugs, ht leads ect. Is the check engine light working - it should come on for about 10 seconds when you first turn on uhe ignition then go out?

hope you can get it sorted soon !!!

Please Log in or Create an account to join the conversation.

More
23 Jul 2013 18:25 #19006

if you let me know your username i'll log into the admin on the beat forum and approve your user account

PM sent...
I recently had a lot of sensor probs on my Beat, most of them went away when I pulled the plugs and cleaned up the connectors - the only one I had to replace was the Lambda sensor in the end but it was a bit of trial and error!

burn and coast sounds like a bit of a pain, I assume you've checked all the normal stufff like plugs, ht leads ect. Is the check engine light working - it should come on for about 10 seconds when you first turn on uhe ignition then go out?

I've only driven it a few times so far! Engine check light is working and not showing any error codes.

Got a track day (Morini Riders Club) coming up on Friday at Cadwell, so any real investigation will have to wait.

It starts and idles fine and pulls cleanly well past the redline. Fuel economy is going to exceed 100 miles on 15 quids worth of slightly expensive fuel. It's just a bit annoying to drive in traffic. It will get sorted, even if it has to be Megasquirted.

Thanks all for the welcome.

Please Log in or Create an account to join the conversation.

More
23 Jul 2013 19:43 #19008

It starts and idles fine and pulls cleanly well past the redline. Fuel economy is going to exceed 100 miles on 15 quids worth of slightly expensive fuel. It's just a bit annoying to drive in traffic. It will get sorted, even if it has to be Megasquirted.

A standard, unmodified, Beat will run fine on standard(95) pump fuel - it's a very well designed Honda engine, until you start playing with it, then they do turn a bit fragile.

In my opinion (although I'm sure a few people will disagree) the red line on a Beat is a target not a warning (the warning is the rev limiter cutting in!)

So a Morini 350/500 owner, I love Italian V-Twins :)

Please Log in or Create an account to join the conversation.

More
23 Jul 2013 19:59 #19009

fxdlidon wrote:

A standard, unmodified, Beat will run fine on standard(95) pump fuel - it's a very well designed Honda engine, until you start playing with it, then they do turn a bit fragile.

It was expensive 95 Octane! With the gauge on empty I wasn't taking a risk.
So a Morini 350/500 owner, I love Italian V-Twins :)

Morini 125, 250, 350(s), 400, 500, Binachi Tonale & Chervino, two Gilera CXs and a 1929 Favor 350. www.morini-mania.co.uk

Please Log in or Create an account to join the conversation.

More
23 Jul 2013 20:06 #19010

Only remember lusting after the 350/500, back when my balance was ok and I could still drive bikes :)

Please Log in or Create an account to join the conversation.

More
23 Jul 2013 21:53 #19016

Just been outside resetting the ignition timing (with the service link in!). It took quite a while as I kept getting interrupted by phone calls from a self confessed mechanical incompetent who's Morini I just recommissioned. His rear brake was sticking and I had to talk him through rear wheel removal and diagnosis and cure of a partially seized operating cam. The timing was out, but correcting it has not cured the problem. It will miss-fire with no load as I gradually open the throttle and you can see the timing jitter as it does so. Whether this is because the rpm is varying, or because the ignition itself is the cause, I'm not sure. I've been through a few of the connectors, which all appeared nice and clean.

Please Log in or Create an account to join the conversation.

23 Jul 2013 22:22 #19018

What condition is your distributor in? I had a lot of weird problems with my beat when the ecu lead on the dizzy was corroded and damaged... just a thought.
:)

Hello and welcome btw.
B)


Author of The Ruins of Rytus Series
Sample, purchase or find out more at:
www.RuinsofRytus.com

Connect with me:
Facebook
Twitter
LinkedIn

Please Log in or Create an account to join the conversation.

Moderators: TADOAdam Kenneydazran
Time to create page: 0.286 seconds
Powered by Kunena Forum